Issue type in japanese

for some weird reason the issue type is displayed in japanese. I tried to change language, but the problem persisted

Any help?

Hi @ceothormaya , welcome to Nulab community!

Please access your Nulab account via the link below, and take a screenshot showing your chosen language.
Ref: Redirect - Nulab Apps

Next, please access the Space Settings: go to the Global Navigation > Select your Profile icon > Space Settings > Language and time
and take a screenshot showing your chosen language.

Kindly send the 2 screenshots to

Thank you for your time and patience!

I would feedback that new sign-ups are still getting this language default set incorrectly.

Hi, could you please check if you have chosen “English” in the space settings and personal settings?

If English is chosen for both settings, please go to the project, click “Project settings” (left hand menu), and go to “Issue Types” page, then delete those Japanese issue types by clicking the “X” button.
Reference article

Then create your desired issue types.

If you have further inquiries, kindly let us know.
We are very sorry for the inconvenience caused!

Oh I fixed it based on this article but I was making the point that I had just signed up to look at the product and it was set wrong, seems a bad first UX you’d probably want to solve for new users.

Thank you so much for your feedback!
I have shared it with our Dev team.